Hosted Planet/Planet Mobile Planned Maintenance Update
Maintenance
in progress
14 hours 8 minutes
2025-09-19T17:00:00.0000000Z
Hosted Planet/Planet Mobile Planned Maintenance Update
Status: in progress
Start:
2025-09-19T17:00:00.0000000Z
Estimated Duration: 3239 minutes
Affected Components:
EMEA
Planet
Planet - Mobile
Update
2025-09-19T17:00:00.0000000Z
2025-09-19T17:00:00.0000000Z
Dear MRI Client,
Please be advised that a scheduled maintenance for MRI hosted Planet and On-Premise clients using Planet Mobile will be taking place on the following date(s):
Friday 19th September from 18:00 BST to 23:59 BST on Sunday 21st September
During this time, your Planet system will be unavailable.
If you have any questions or concerns, please contact Client Support via the
myMRI Client Portal
.
Thank you,
MRI Software