Contract Intelligence Planned Maintenance Update

Maintenance
April 24th 2025, 4:00:00pm

Contract Intelligence Planned Maintenance Update

Status: closed
Start: April 24th 2025, 2:00:00pm
End: April 24th 2025, 4:00:00pm
Duration: 2 hours
Affected Components:
Americas APAC EMEA Contract Intelligence Contract Intelligence Contract Intelligence
Update

April 24th 2025, 2:00:00pm

April 24th 2025, 2:00:00pm

Dear MRI Client,

A Planned Maintenance Update (PMU / MCI 7.04.03.00) for Contract Intelligence will be applied on April 24th, 2025 @ 10:00 EST

For a detailed summary of this update, your company's Designated Support Contact (DSC) can access the full release notes from the myMRI Client Portal

If this update is delayed, additional information will be posted on the MRI Notifications page.

If you have any questions or concerns, please contact Client Support via the myMRI Client Portal or by calling one of the numbers listed on our website.

MRI Software


MRI Software

Resolved

April 24th 2025, 4:00:00pm

April 24th 2025, 4:00:00pm

Update completed.