MRI Angus Planned Maintenance Update

Maintenance

MRI Angus Planned Maintenance Update

Status: closed
Start:
End:
Duration: 3 hours
Affected Components:
Americas Angus
Update

Dear MRI Client,

A Planned Maintenance Update (PMU) for MRI Angus  will be applied on April 28th, 2024.

If this update is delayed, additional information will be posted on the MRI Notifications page.

If you have any questions or concerns, please contact Client Support via the myMRI Client Portal or by calling one of the numbers listed on our website.

MRI Software

Resolved

We are pleased to inform you that the scheduled maintenance has been successfully completed.