MRI Sales and Lettings - Scheduled SaaS maintenance

Maintenance

MRI Sales and Lettings - Scheduled SaaS maintenance

Status: closed
Start:
End:
Duration: 1 day 18 hours 27 minutes
Affected Components:
EMEA Sales and Lettings
Update

Dear MRI Client,


Please be advised that a scheduled SaaS maintenance for MRI Sales and Lettings will be taking place on the following date(s): 

Saturday, 13th April from 18:00 (BST) until 12:00 (BST) on Sunday, 14thApril

During this time, your system will be unavailable. 

If you have any questions or concerns, please contact Client Support via the myMRI Client Portal.

Thank you,

MRI Software


Thank you,

MRI Software

Resolved

The scheduled SaaS maintenance for MRI Sales and Lettings has been completed.

If you have any questions or concerns, please contact Client Support via the myMRI Client Portal.