MRI Workplace Central - Essential SaaS maintenance

Maintenance

MRI Workplace Central - Essential SaaS maintenance

Status: closed
Start:
End:
Duration: 18 hours
Affected Components:
Americas EMEA Workplace Central Workplace Central
Update

Dear MRI Client,

Please be advised that an essential SaaS maintenance for MRI Workplace Central will be taking place on the following date(s): 

Saturday, 13th April from 18:00 (BST) until 12:00 (BST) on Sunday, 14th April

During this time, your system will be unavailable for use. 

If you have any questions or concerns, please contact Client Support via the myMRI Client Portal.


Thank you,

MRI Software

Resolved

The scheduled SaaS maintenance for MRI Workplace Central has been completed.

If you have any questions or concerns, please contact Client Support via the myMRI Client Portal.

Thank you,

MRI Software