MRI Public and Affordable Housing - Property Management X - Update

Maintenance

MRI Public and Affordable Housing - Property Management X - Update

Status: closed
Start:
End:
Duration: 5 days 22 hours 45 minutes
Affected Components:
Americas Property Management X PMX X.5 Americas - Venus
Update

Dear MRI Client,

 We regret to inform you that some of the compliance forms may currently be unavailable.  We are working quickly to resolve this matter and will communicate once corrected.  We appreciate your patience as this matter is being worked on.  If you have any questions or concerns, please contact Client Support via the myMRI Client Portal or by calling one of the numbers listed on our website.

 Thank you,

MRI Software

Resolved

We are pleased to inform you that the scheduled maintenance has been successfully completed.