MRI ProLease Central and MRI ProLease Workplace & Maintenance - Performance Degradation

Incident

MRI ProLease Central and MRI ProLease Workplace & Maintenance - Performance Degradation

Status: closed
Start:
End:
Duration: 5 hours 58 minutes
Affected Components:
Americas ProLease ProLease Central ProLease Workplace/Maintenance
Update

Dear MRI Client,

We are currently experiencing an unexpected outage.  MRI ProLease Central and MRI ProLease Workplace & Maintenance are temporarily unavailable. Our team is actively investigating the issue and working to restore service as quickly as possible.

We apologize for the inconvenience and appreciate your patience. Updates will be provided as we learn more.

Thank you for your understanding.

MRI Software

Update

Dear MRI Client,

MRI ProLease Central and MRI ProLease Workplace & Maintenance are now available; however, some users may be experiencing slow performance. Our teams are actively investigating the issue with the highest priority and are working to resolve it as quickly as possible.

We appreciate your patience and understanding.

Regards,
MRI Software

Resolved

Dear MRI Client,

We would like to inform you that all sites are now fully operational, with performance levels back to normal. You may experience a brief delay during the initial page load, which should clear after the first interaction.

As part of our standard post-recovery checks, we are reviewing system components to ensure everything is functioning as expected. If you happen to notice anything unusual, please feel free to reach out — we’ll be happy to assist.

Thank you for your continued trust and understanding.

MRI Software