MRI ProLease Central and ProLease Workplace & Maintenance - Planned Maintenance Update

Maintenance

MRI ProLease Central and ProLease Workplace & Maintenance - Planned Maintenance Update

Status: closed
Start:
End:
Duration: 21 hours 30 minutes
Affected Components:
Americas ProLease ProLease Central ProLease Workplace/Maintenance
Update

Dear MRI Client,


Please be advised that MRI ProLease Central and ProLease Workplace & Maintenance servers will be migrating to Microsoft Azure Cloud. This migration will necessitate network configuration changes on your corporate network.

The designated migration window is set for April 19-20, 2025.

The migration is currently scheduled to finish on Sunday, April 20, 2025, at 2:00AM EDT.

We plan to send out another notification once the migration is complete.

MRI Software

Resolved

Dear MRI Client,

We’re pleased to inform you that the migration of MRI ProLease Central and ProLease Workplace & Maintenance servers to Microsoft Azure Cloud was successfully completed on Saturday, April 19, 2025, at 11:30:00 PM EDT.

As a reminder, this migration requires network configuration changes on your corporate network to ensure continued access to the application. If you haven’t already made these updates, we encourage you to do so as soon as possible.

Thank you for your continued support. If you have any questions or encounter any issues, please don’t hesitate to reach out to our support team.

MRI Software