Property Tree | Planned Maintenance Update

Maintenance

Property Tree | Planned Maintenance Update

Status: closed
Start:
End:
Duration: 10 hours 37 minutes
Affected Components:
APAC Property Tree
Update

Hi there,

We will add some new enhancements to Property Tree on Tuesday, the 13th of February 2024, between 10:00 pm and 12:00 am AEDT

Please note that Property Tree will not be available during this time. 

We apologise for any inconvenience that this may cause. If you have any questions or concerns, please contact Support

The MRI Property Tree Team

Resolved

We are pleased to inform you that the scheduled maintenance has been successfully completed.