Workspeed Planned Update

Maintenance

Workspeed Planned Update

Status: closed
Start:
End:
Duration: 8 hours
Affected Components:
Americas Workspeed Reporting
Update

Dear MRI Client,

Please be advised that a scheduled SaaS maintenance for Workspeed will be taking place on the following date(s): 

Saturday, 10th February from 22:00 (EST) until 06:00 (EST) on Sunday, 11th February.

During this time, your system will be unavailable for use.

If you have any questions or concerns, please contact Client Support via the myMRI Client Portal.

Thank you,

MRI Software

Resolved

Dear MRI Client,

We are pleased to inform you that the scheduled maintenance has been successfully completed.

Thank you,

MRI Software