MRI Angus Planned Maintenance Update

Maintenance

MRI Angus Planned Maintenance Update

Status: closed
Start:
End:
Duration: 3 hours
Affected Components:
Americas Angus
Update

Dear MRI Client,

A Planned Maintenance Update (PMU) for MRI Angus  will be applied on November 19, 2023.

This update includes:

  • NEW - Added contextual help support for new work order list and updated announcement module.
  • NEW - Added link to MRI's standard Privacy Policy and Terms of Use documents on the Employee Portal (ESI) and Service Portal (Portal).
  • CHANGED - User roles other than Corporate Administrators can now modify an employee's MRI Identity Provider settings when creating or editing an employee profile.
  • CHANGED - Increased the size of the message body for the new create announcements screen.
  • FIXED - Users will no longer receive error message when navigating to the new home page via an old browser bookmark.
  • FIXED - PM Impairment warning, missed completion, and overdue email notifications will now be sent to users.

For a detailed summary of this update, your company's Designated Support Contact (DSC) can access the full release notes from the myMRI Client Portal

If this update is delayed, additional information will be posted on the MRI Notifications page.

If you have any questions or concerns, please contact Client Support via the myMRI Client Portal or by calling one of the numbers listed on our website.

MRI Software

Resolved

We are pleased to inform you that the scheduled maintenance has been successfully completed.